problème avec le curent .html

Forum dédié à la mise en ligne de vos données météos relevées avec WsWin.
mm91
Participation 6
Participation 6
Messages : 2502
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Message par mm91 » 07 déc. 2007, 23:19

webmaster a écrit : Tu sais Michel, un Custom de base ressemble grandement à un Current…
Ca m'étonne de quelqu'un d'expérimenté et observateur comme toi !

Par exemple, dans la grande majorité des cas, la première chose qu'on change c'est ça:

"XXX m niveau au-dessus de la mer"

que l'on remplace par

"XXX m au dessus du niveau de la mer

ou par

"altitude 163 m" (comme ici)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

mm91
Participation 6
Participation 6
Messages : 2502
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Message par mm91 » 07 déc. 2007, 23:25

vals a écrit :
Mais ça ne nous dit pas pourquoi eole n'a pas de vent, ce qui est un comble.
Je ne pouvais pas la rater celle-là avant que Tudgur ne me la prenne :lol:
Quand on veut afficher un id non utilisé ça indique 0 ou autre chose ?
@+
la réponse est dans mon post de 21 h 40
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 08 déc. 2007, 10:50

mm91 a écrit :
webmaster a écrit : Par exemple, dans la grande majorité des cas, la première chose qu'on change c'est ça:

"XXX m niveau au-dessus de la mer"

que l'on remplace par

"XXX m au dessus du niveau de la mer

ou par

"altitude 163 m" (comme ici)
C’est vrai quand on commence à comprendre le fonctionnement, pas quand on sort son premier custom !

Et bien moi ce tableau tronqué m’étonne toujours, des cellules vides ou les tags à la place de la valeur me choqueraient moins.

Je ne comprends pas ton message Michel, comment modifier le current.html original à part en cochant les options dans la page de configuration ?
Tu ne peux rien faire de plus !
Cordialement

Rieux

Tudgur
Participation 6
Participation 6
Messages : 1755
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Message par Tudgur » 08 déc. 2007, 12:16

Je débarque un peu dans votre discussion, mais chez moi le current est un custom !!! :!: :shock:
Après achat et installation de wswin, je n'ai jamais eu de création automatique d'un current, il m'a fallu votre aide...et celle du site de chamois si je me souviens bien.
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 08 déc. 2007, 12:37

Oui c’est vrai qu’il c’était passé un truc bizarre chez toi je crois.
Mais par défaut un current est généré et les quelques options que propose Werner sont dans l’onglet Current du menu Internet.
Avant que ces options existent, WsWin se servait d’un fichier TXT en modèle, depuis il ne sert plus à rien et peut être supprimé.
Cordialement

Rieux

mm91
Participation 6
Participation 6
Messages : 2502
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Message par mm91 » 08 déc. 2007, 12:43

Oui, je pense que Rieux a raison, on ne peut pas modifier un current (à part ce qui est prévu dans le menu de Wswin).
Je modifie donc mon message de 22 h 41(suppression partielle) et m'excuse auprès de Eole.

Mais il reste quelque chose de pas clair, comme tu dis.
Je crois que c'était faisable avant.

Pour ma part, c'est aussi Chamois qui m'avait fait mon custom (que j'ai largement modifié par la suite)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

eole
Participation 0
Participation 0
Messages : 16
Enregistré le : 01 nov. 2007, 18:15
Localisation : Awans (prov. Liège)
Contact :

Message par eole » 08 déc. 2007, 13:49

je ne sais pas si cela a de l'importance mais la version de WsWin que je possède est le V 2.91.2

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Message par webmaster » 08 déc. 2007, 14:04

Oui nous avions vu, c’est en bas de ta page et c’est la première chose que l’on regarde.
Pourquoi travailler avec une si ancienne version :?:

Pour moi tu ne pourras pas avoir un meilleur affichage sans passer par un fichier Custom, et encore sous réserves que les tags soient les mêmes avec la WS3600 et la Vantage.

Peut être Vals s’en souvient-il !
Cordialement

Rieux

jackT
Participation 4
Participation 4
Messages : 635
Enregistré le : 29 mars 2007, 11:24
Localisation : Sciez (74)
Contact :

Message par jackT » 08 déc. 2007, 16:49

eole a écrit :merci pour le renseignement, c'était bien cela, les icônes ne n'était pas dans le fichier du site, le problème est résolu, mais, j'ai encore un petit souci toujours dans le curent.html, la direction des rafales reste bloquée à 0° N alors qu'aujourd'hui le vent venait d'ouest.
merci d'avance.
eole
C'est à vérifier bien sûr, mais il me semble que la WS3600 ne donne que 3 valeurs pour le vent : vitesse et direction du vent (dernière mesure instantanée avant la capture) et vitesse de la rafale max, mais pas de direction du vent de la rafale max.
Ce qui expliquerai que cette valeur est toujours nulle dans ton "current".

eole
Participation 0
Participation 0
Messages : 16
Enregistré le : 01 nov. 2007, 18:15
Localisation : Awans (prov. Liège)
Contact :

Message par eole » 08 déc. 2007, 17:29

voilà je viens d'installer la dernière version de WsWin et la les choses semblent s'arranger !! je n'ai plus le problème avec les rafales ni avec la direction des rafales, c'est vrai que sur la ws3600 il n'y a que 3 valeurs. Il reste juste la phrase dans l'entête "146 m au dessus de la mer" que j'aimerais enlever, j'ai essayer avec le bloc notes mais quand il y a une nouvelle mise a jour qui se fait le problème revient !
eole

jackT
Participation 4
Participation 4
Messages : 635
Enregistré le : 29 mars 2007, 11:24
Localisation : Sciez (74)
Contact :

Message par jackT » 08 déc. 2007, 17:32

mm91 a écrit :Oui, je pense que Rieux a raison, on ne peut pas modifier un current (à part ce qui est prévu dans le menu de Wswin).
Je modifie donc mon message de 22 h 41(suppression partielle) et m'excuse auprès de Eole.

Mais il reste quelque chose de pas clair, comme tu dis.
Je crois que c'était faisable avant.

Pour ma part, c'est aussi Chamois qui m'avait fait mon custom (que j'ai largement modifié par la suite)
Par défaut et sans définir aucun fichier personnalisé, wswin crée automatiquement un "current.html" d'après un modèle interne et que l'on ne peut pas modifier.

Mais si on utilise et active un fichier personnalisé "custom.txt", avec en première ligne la commande <!-- %customfile=current.html% --> le fichier "current.html" calculé par wswin sera fait alors sur la base du contenu de "custom.txt" et non plus selon le modèle interne de wswin.
Il y a d'ailleurs dans le répertoire de wswin un fichier "current_en.txt" qui est tout prêt pour cela (...mais en version anglaise). Il suffit alors de l'adapter à ses besoins.

Avatar du membre
vals
Participation 5
Participation 5
Messages : 814
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 08 déc. 2007, 17:51

eole a écrit :voilà je viens d'installer la dernière version de WsWin et la les choses semblent s'arranger !! je n'ai plus le problème avec les rafales ni avec la direction des rafales, c'est vrai que sur la ws3600 il n'y a que 3 valeurs. Il reste juste la phrase dans l'entête "146 m au dessus de la mer" que j'aimerais enlever, j'ai essayer avec le bloc notes mais quand il y a une nouvelle mise a jour qui se fait le problème revient !
eole
Tu as regardé du côté de internet réglages onglet généralité rubrique emplacement ?
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

jackT
Participation 4
Participation 4
Messages : 635
Enregistré le : 29 mars 2007, 11:24
Localisation : Sciez (74)
Contact :

Message par jackT » 08 déc. 2007, 18:09

eole a écrit :.. Il reste juste la phrase dans l'entête "146 m au dessus de la mer" que j'aimerais enlever, j'ai essayer avec le bloc notes mais quand il y a une nouvelle mise a jour qui se fait le problème revient !
eole
eole, comme expliqué un peu plus haut, tu ne peux pas modifier le contenu du fichier "current.html" généré par défaut.

Mais tu peux par contre en définir un toi même comme fichier html personnalisé.

Si c'est du chinois pour toi, va voir d'abord les pages du site de Rieux à ce sujet... et particulièrement http://www.rieux-marne.net/meteo/pages/ ... custom.htm

eole
Participation 0
Participation 0
Messages : 16
Enregistré le : 01 nov. 2007, 18:15
Localisation : Awans (prov. Liège)
Contact :

Message par eole » 08 déc. 2007, 18:58

Et bien voilà !!
j'ai suivi les conseils de jackT et les instructions sur le site de Rieux et tout est OK , j'ai une super page "current" qu'il me reste encore à peaufiner, mais maintenant que je sais comment ça marche !!

Un grand merci à vous tous, vous êtes super sympas !

eole

eole
Participation 0
Participation 0
Messages : 16
Enregistré le : 01 nov. 2007, 18:15
Localisation : Awans (prov. Liège)
Contact :

Message par eole » 08 déc. 2007, 22:29

et m............. c'est pas vrai, !!!!!
je suis revenu a la case départ dans mon current sauf la couleur et toujours l'entête maintenant en allemand

Répondre