Fichiers NOAA ....(moi aussi)

Forum dédié aux différents paramétrages de WsWin, et il y en a…
Tudgur
Participation 6
Participation 6
Messages : 1711
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar Tudgur » 22 Juin 2013, 22:53

Super !!!
J'ai éclaté de rire et je garde ta prose !!!
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 22 Juin 2013, 22:54

Réponse au HS de Tugdur
    Tout le monde sait de ce coté ci de l'Aber Wrac'h que le climat n'est pas du tout le même que 5km plus au nord.
    Depuis le temps que je parle d'inauguration de ma station il va falloir prévoir à cette occasion un étalonnage du pluvio au champagne, mais j'avais dit :"quand il fera beau".

Blague à part, merci pour ta vigilance et ton œil critique, est ce qu'on cause d’étalonnage par mails , est ce que le sujet existe sur le forum, ou faut il en ouvrir un ?
Pour le moment je retourne aux "noaa"

Là je fait "éditer" :
je suis bien d'accord avec le Webmaster, ça fait un peu lèche bottes je sais, mais pour aller à Plouguerneau il en faut des bottes .
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3

Tudgur
Participation 6
Participation 6
Messages : 1711
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar Tudgur » 22 Juin 2013, 23:07

A Plouguerneau, c'est l'enfer pour les pluvios !!!
Pour l'étalonnage, ce peut être par mail ou le forum d'Infoclimat...
Plusieurs fils sur le sujet.
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 22 Juin 2013, 23:44

Essayons de redevenir sérieux( j'ai toujours un peu de mal):

    J'ai repris le script fourni par Rieux, ça commençait par :
    <div id="contenu">

    <?php .....

    j'ai laissé le div ?
    ce script a été enregistré comme climatoa.php, je l'ai placé dans le dossier "essai" avec les .php précédents (climatom, redir**, redir**,)


    j'ai récupéré son noaa2013.txt ainsi que mes noaa20133/ 4/ 5 /6 j'ai tout mis dans "essai" que j'ai placé à la racine de mon site .



Y'a de la division par zéro comme tu annonçais( ça trouble toujours un prof de math, même à la retraite)
Mais des résultats "y'en a aussi"
Modifié en dernier par Landéda le 01 Aoû 2013, 11:20, modifié 1 fois.
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2661
Enregistré le : 12 Déc 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar webmaster » 23 Juin 2013, 08:55

Bonjour,
webmaster a écrit :A mon avis, ça ne fonctionnera pas, ou je me mords un œil !

Je m'en doutais, tu dois le faire exprès.

Donc concrètement, si tu reprends le code de base de Chriss, en générant les fichiers avec les bon templates, çà fonctionne ou pas ?
Cordialement

Rieux

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 23 Juin 2013, 09:59

Je venais d'envoyer un mail à Tugdur en lui disant "à ce soir", mais avec le temps qu'il fait j'y suis revenu et là que vois je ???
Un miracle cette nuit:

ça marche !!!!
va falloir faire un débriefing ou une autopsie pour savoir ce qui c'est passé ?????
Une première question par exemple : d'où viennent les données de janvier, février ?
Mais comme ça marche, une autre question surgit immédiatement : où entrer les normales?
Je vais fouiller dans le forum ça doit bien exister quelque part
Merci à Rieux et à tous ceux qui ont sué sur ce sujet
Modifié en dernier par Landéda le 03 Aoû 2013, 21:55, modifié 1 fois.
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2661
Enregistré le : 12 Déc 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar webmaster » 23 Juin 2013, 10:53

Landéda a écrit :ça marche !!!!
va falloir faire un débriefing ou une autopsie pour savoir ce qui c'est passé ?????

Les miracles en programmation sont assez rare, voir inexistant !
Perso je pense qu'il y a eu une modification chez ton hébergeur.
Landéda a écrit :Une première question par exemple : d'où viennent les données de janvier, février ?

Tu n'as que les extrêmes qui se trouvent dans le fichier de données annuelles.
Landéda a écrit :Mais comme ça marche, une autre question surgit immédiatement : où entrer les normales?

Dans WsWin, menu Météo, Données statistiques, onglet Paramètres.
Cordialement



Rieux

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 25 Juin 2013, 00:20

Tentative pour y voir plus clair:
Dans mon post du 21 juin à 23h05 "ça marchait pas"
J'utilisais à ce moments les scripts de Chris modifiés par le script précédent de Rieux (post de 22h34)
Le lendemain (22 juin 17h34) Rieux me propose un autre script que j'essaye ailleurs :
ce script a été enregistré comme climatoa.php, je l'ai placé dans le dossier "essai" avec les .php précédents (climatom, redir**, redir**,)


j'ai récupéré son noaa2013.txt ainsi que mes noaa20133/ 4/ 5 /6 j'ai tout mis dans "essai" que j'ai placé à la racine de mon site .


Vous pouvez admirez le résultat ici : http://www.meteo-landeda.org/essai/climatoa.php.

ça marchait pas, je reprends le poste de Vals qui disait:
Bonjour.
Avec ftp-uploader 1.4 j'avais eu ce même genre de problème.
La solution que j'avais trouvé:
Dans Projekte \Projektverwaltung onglet FTP-Programm
La case Einstellungen für den FTP-Uploader zum Transfermode Auto
Il faut rajouter ;txt

Je fouille dans FTP uploader :
dans Projekte/Vervalten/Uploader/Uploader optionen ; on trouve l'option suivante :


Image
Je rajoute ;txt
Aucun résultat immédiat.
Le lendemain matin il s'affichait: la climatologie annuelle de 2013 et la climatologie mensuelle de juin.
Pour ce que je crois comprendre: au premier transfert après minuit, FTP uploader a transféré , avec le nouveau réglage, les deux fichiers à modifier suite au changement de date: 2013 et juin2013
qu'en pensez vous ?????
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3

Avatar du membre
vals
Participation 5
Participation 5
Messages : 825
Enregistré le : 13 Déc 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar vals » 25 Juin 2013, 09:10

Ouf ça avance.
Quel est le pas de transfert de ton ftp ?
A chaque fois le ftp ne transfère que les nouveaux fichiers ou les fichiers modifiés.
Je ne me souviens plus si les noaa ne sont mis à jour que lors des "grandes" mises à jour.
Ça peut expliquer le retard à l'affichage.

2 jours sans pluie, pluvio peut-être coincé !! :cool:
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2661
Enregistré le : 12 Déc 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar webmaster » 25 Juin 2013, 20:32

Bonsoir,
Landéda a écrit :Aucun résultat immédiat.
Le lendemain matin il s'affichait: la climatologie annuelle de 2013 et la climatologie mensuelle de juin.

Pour moi tu fais fausse route, sans que j'ai une réelle explication. Mais il ne faut pas oublier qu'avant tout çà, j'ai chargé ton fichier de données ainsi que les scripts que vous aviez pris sur le site de Chriss. J'ai placé l'ensemble ici et cela fonctionnait parfaitement !
Si ton fichier de données avait mal été transmis, j'en aurais récupéré une copie altérée qui n'aurait pas fonctionné chez moi et ce n'était pas le cas.

Mais bon, le principal est que cela fonctionne, tu n'as plus qu'à mettre tous ça en ligne et à ajouter un lien pour y accéder sur ton site.
Cordialement



Rieux

Tudgur
Participation 6
Participation 6
Messages : 1711
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar Tudgur » 25 Juin 2013, 20:51

webmaster a écrit :...tu n'as plus qu'à mettre tous ça en ligne et à ajouter un lien pour y accéder sur ton site.

Ouais, que je puisse surveiller ta pluvio !!! :lol:
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 25 Juin 2013, 23:59

Bonsoir, je suis de retour
Pour Vals: le ftp se fait toutes les 5mn47! , deux jours sans pluie, même en Bretagne Nord ça arrive, mais si je compare avec mon voisin Tugdur l'un de nous a un problème de pluviométrie : on donc peut raisonnablement penser que c'est moi, à suivre. Sur les conseils de Tugdur je vais déplacer mon ISS ça sera l'occasion d'une grande révision.

Pour Rieux et Tugdur j'ai mis un lien "climato" (provisoire) dans le menu.

Rieux à tout à fait raison : dans mon scénario y'a au moins un truc qui ne colle pas: mes fichiers en l'état fonctionnaient chez lui et pas chez moi ?

Dans ma climto mensuelle de juin il y'a je pense des pbs dans la dernière ligne( moyennes) au moins pour les températures: une moyenne des min de 17,5 et absence d'affichage pour la moyenne des max
Vous avez sans doute remarqué que mes connaissances en PHP étaient rudimentaires ; j'ai mis ce site en place en procédant beaucoup par essai/erreur à partir de la consultation de différents sites et forums
Je vais surveiller ces résultats et tenter d'en améliorer la présentation

Merci à tous les trois

Je réédite mon post:

Je viens de parcourir ce forum et j'ai trouvé une discussion assez proche entre les trois mêmes personnes, en bas cette page en nov 2012

en particulier :
Bonjour,

Moi je ne comprends pas pourquoi en récupérant ton fichier hier, cela fonctionnait parfaitement chez moi !

_________________
Cordialement

Rieux
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3

Avatar du membre
vals
Participation 5
Participation 5
Messages : 825
Enregistré le : 13 Déc 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar vals » 26 Juin 2013, 09:38

Pour ma part je pense que c'est simplement une question de réglage du ftp.
C'est dans le type de transmission ASCII ou EBCDIC des .txt.
Peut-être que le ftp de Rieux transmet par défaut les .txt en ascii alors qu'avant la modif ton ftp transmettait par défaut les .txt en ebcdic.

Tout le monde sait qu'en Bretagne il ne pleut que deux fois par an.
Une fois 9 mois et une fois 3 mois.
Bon ok je :arrow:
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Tudgur
Participation 6
Participation 6
Messages : 1711
Enregistré le : 13 Mai 2007, 16:47
Localisation : 29880 Plouguerneau
Contact :

Re: Fichiers NOAA ....(moi aussi)

Messagepar Tudgur » 26 Juin 2013, 13:01

vals a écrit :Bon ok je :arrow:

Ben heureusement pour toi que t'es sorti !!!
dois-je te rappeler ta pluvio de mai ? :lol:
Ici, 62.6mm et seulement 33mm dans les zones désertiques de Landéda...
Cordialement.

Tudgur
http://meteo-plouguerneau.fr

Landéda
Participation 0
Participation 0
Messages : 34
Enregistré le : 09 Déc 2012, 00:18
Localisation : 29870 Landéda

Re: Fichiers NOAA ....(moi aussi)

Messagepar Landéda » 03 Aoû 2013, 23:04

Bonsoir à tous
Je reprends ce sujet car j'ai (encore) fait des "bêtises"
Suite aux efforts de Rieux Vals et Tugdur, javais un affichage qui me semblait convenable, de mes archives météo.
J'ai voulu l'améliorer erreur!
J'avais vu "ici et là " des tableaux avec affichage de graphiques au survol de la souris: je me suis encore dit moi aussi.
J'ai trouvé sur ce forum une discussion qui débute en aout 2007 ici.
Les derniers messages sont de début 2011, et après ses différentes interventions JackT nous fournit les fichiers cherchés .Merci à lui.
J'ai donc suivi ses conseils et installé son "affichage des tableaux sans données de rayonnement solaire "
J'ai placé ses deux ***.php à la racine de mon site,
j'ai shunté le dossier C\Wswin\html\text et redéfini le chemin de création des templates en :C\Wswin\html
j'y ais déplacé les différents noaa20******.txt existants,
j'ai placé ses template_noaa_m et template_noaa_y dans Wswin
j'ai modifié une ligne dans son script: *. Js
J'ai cru que ça marchait mais comme vous pouvez le voir il n'en est rien:
http://www.meteo-landeda.org/climatom.php

Les couleurs ne fonctionnent plus, y'a des jours de gelée en aout! plein de données aberrantes dans la climatologie annuelle y compris des normales que je n'ai jamais rentrées .

J'avais envoyé un mail à meteo-labrise, il utilise cet affichage, il m'a fait parvenir un lien de téléchargement vers ces mêmes fichiers, donc chez eux ça marche!

J'ai donc du cafouiller dans mes différents changements ?

quelqu'un a t'il une idée: faut 'il tout virer et repartir à zéro, mais alors que faut'il virer ?

La perte de données ne serait pas une catastrophe, Tugdur m'a depuis un certain temps signalé deux problèmes dans ma station: une surchauffe et le pluvio à ré-étalonner. je repartirais alors sur des bases plus saines

Merci pour vos conseils et suggestions
Cordialement :Jean
http://www.meteo-landeda.org/
Vantage Pro2
WsWin
FTP-Uploader2.0.3


Retourner vers « Réglages »

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 1 invité