Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Forum dédié aux problèmes d’utilisation du logiciel, une fonction que vous cherchez et que vous ne trouvez pas.
Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 28 sept. 2012, 18:04

Bonjour,
Ce soir, comme souvent, je fais une petite correction de pluvio, je rajoute 0.2mm.
A la suite de l'opération, je constate que Wswin s'ouvre avec la tâche planifiée, relève les données dan le datalogger mais ne crée aucun fichier, sauf ws_report.txt !!! Il n'ouvre pas le logiciel Ftp et la petite fenêtre fermeture ne s'ouvre pas.
De plus, impossible de le fermer, soit par la croix de la fenêtre soit par fichier/quitter programme...
J'ai remplacé le fichier WSWIN.CFG par celui sauvegardé hier matin, idem...

Avez-vous déjà rencontré ce problème ?
Merci
Modifié en dernier par Tudgur le 29 sept. 2012, 06:34, modifié 2 fois.
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par webmaster » 28 sept. 2012, 18:23

Bonsoir Tudgur,

Deux truc à essayer:
-Regarder dans le fichier d'erreur de WsWin voir s'il y a une info.
-Regarder dans les fichiers générés en les classant par date de modification de manière à trouver s'il n'y en a pas un à la traîne, si c'est le cas il est probablement corrompu. Le supprimer et relancer un cycle en redémarrant le PC auparavant.
Cordialement

Rieux

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 28 sept. 2012, 19:46

Salut,

Dans WSWINERR.TXT il y a de nombreux "post failed" depuis l'apparition du problème, mais pas toutes les 5min !
Il arrive en effet que certaines mises à jours se fassent tardivement après l'ouverture de Wswin par la tache planifiée...
J'ai ainsi vu celle de 19h35, de 20h05 de 20h30, et maintenant de20h40, fin de l'envoi des fichiers à 20h44 (ce devrait être avant 20h42) et la Wswin se ferme normalement...
Très étrange !
Par ficher généré, tu veux dire un des customs ?
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

Avatar du membre
webmaster
Site Admin
Site Admin
Messages : 2611
Enregistré le : 12 déc. 2006, 20:54
Localisation : Rieux 51 FRANCE
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par webmaster » 28 sept. 2012, 19:56

webmaster a écrit :Par ficher généré, tu veux dire un des customs ?
Oui, ça m’arrive de temps en temps sans raisons particulières.
Cordialement

Rieux

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 28 sept. 2012, 21:38

Qu'entends-tu par un fichier à la traine ?
Après la mise à jour réussie de 20h40, la suivante a eu lieu à 22h15 et tous les customs sont générés !!!

Edit : Après la lecture des données du datalogger, Wswin ne crée aucun graphique : il n'y a pas de "balayage du mois" par exemple.
Par le menu Internet / mes fichiers html wml, mes trois customs sont créés.

Edit 2 : j'ai résolu le problème en remplaçant Wswin32.exe.
Mais comment a-t-il été corrompu ???

Edit 3 : Ce matin, je constate que le problème n'est pas du tout résolu. après plusieurs relevés "normaux" cette nuit.

HELP !!!!!!!!!!!!!!!!!!!!!!!!!!
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

deule-climat
participation 3
participation 3
Messages : 201
Enregistré le : 04 nov. 2010, 13:31
Localisation : Deûlémont, Nord
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par deule-climat » 29 sept. 2012, 07:00

Cela m'arrive par moment. Pour fermer Wswin, j'utilise CTRL+ALT+SUPP et je ferme Wswin dans les processus. Après le redemarrage du logiciel, c'est reparti pour un mois sans problème.

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 29 sept. 2012, 07:19

Mais ici, après Ctrl/Alt/Sup, Wswin se ferme avec difficulté et à la première ouverture, le problème est là !
Bizarrement, cela fonctionne de temps en temps.

Sur mon PC de bureau, j'ai Wswin avec exactement le même paramétrage que sur mon PC météo, les mêmes tâches planifiées, tout à l'identique et ça marche.
Sur mon PC météo, j'ai renommé le répertoire Wswin32 puis copié celui du PC de bureau sur le PC météo : Même problème !!!
Je vais essayé l'opération inverse...
Cela pourrait-il venir du PC météo un peu "fatigué" : depuis quelques mois il est un peu plus bruyant qu'à ses débuts.

Edit : je n'aurais pas dû essayer l'opération inverse :
je renomme le répertoire wswin sur le PC de bureau;
Je copie le répertoire wswin du PC météo sur le PC de bureau : le problème est toujours là;
Je supprime ce répertoire ;
Je reviens à mon répertoire d'origine sur le PC de bureau, Wswin ne marche plus, il présente le même problème !!!
Là, je suis dans la mouise...
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 29 sept. 2012, 09:14

5 relevés consécutifs réussis !
J'ai désactivé Awekas qui semble donc être à l'origine du problème !
Avez-vous un soucis avec Awekas ?
Peut-on avoir ses données sur Awekas en utilisant un custom Php ?
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

gégé
participation 3
participation 3
Messages : 288
Enregistré le : 16 déc. 2007, 09:28
Localisation : Baladou 46600
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par gégé » 29 sept. 2012, 09:17

bonjour
Awekas planté
Cordialement Gérard
http://meteo-baladou.com

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 29 sept. 2012, 09:22

Oui, je viens de voir sur les sites des "voisins" que le lien vers Awekas ne fonctionnait pas non plus !
J'avais eu un problème semblable avec Weather Underground : la connexion restait bloquée et empêchait l'envoi de ms fichiers en FTP.
C'est quand même gênant si le problème survient quand on est absent !
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

gégé
participation 3
participation 3
Messages : 288
Enregistré le : 16 déc. 2007, 09:28
Localisation : Baladou 46600
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par gégé » 29 sept. 2012, 09:31

pour moi Awekas empêche pas l'envoi des fichiers en ftp
Cordialement Gérard
http://meteo-baladou.com

Tudgur
Participation 6
Participation 6
Messages : 1745
Enregistré le : 13 mai 2007, 16:47
Localisation : 29880 Plouguerneau

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par Tudgur » 29 sept. 2012, 09:51

Ce n'est pas l'envoi lui même qui est bloqué.
J'ai l'impression que Wswin commence par se connecter à Awekas aussitôt la lecture des données réalisées (j'utilise Direct Link et non pas un fichier txt).
Puis il balaye le mois, génère les graphiques, les customs, ouvre le logiciel FTP et se ferme.
Mais ici, comme il ne peut se connecter à Awekas, il s'arrête (sans se fermer) après la lecture des données.

Edit : Awekas est "déplanté". J'ai recoché Direct Link et tout fonctionne normalement...
Cordialement.

Tudgur
http://meteo-plouguerneau.fr" onclick="window.open(this.href);return false;

mm91
Participation 6
Participation 6
Messages : 2474
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par mm91 » 12 oct. 2012, 11:00

Tudgur a écrit :Ce n'est pas l'envoi lui même qui est bloqué.
J'ai l'impression que Wswin commence par se connecter à Awekas aussitôt la lecture des données réalisées (j'utilise Direct Link et non pas un fichier txt).
Puis il balaye le mois, génère les graphiques, les customs, ouvre le logiciel FTP et se ferme.
Mais ici, comme il ne peut se connecter à Awekas, il s'arrête (sans se fermer) après la lecture des données.

Edit : Awekas est "déplanté". J'ai recoché Direct Link et tout fonctionne normalement...
Je n’utilise pas AWEKAS, mais j’utilise Wunderground.

Je l’ai programmé (dans Wswin32) pour que toutes les données horaires depuis la dernière connexion soient envoyées à l’ouverture de Wswin32.

(cela n’est possible que par un .bat planifié contenant l’instruction :
« start /d"c:\Program Files\wswin" wswin32.exe /WG », il y a un post sur ce sujet dans ce forum) )

A l’ouverture planifiée de 6 heures chaque matin le transfert vers WG est très long (7 minutes environ)
pendant tout ce temps Wswin32 est bloqué et n’exécute aucune action et aucun enregistrement

cela confirme donc le pb que tu avais avec AWEKAS

Mais cela ne me gène pas du tout ; wswin32 fonctionne parfaitement une fois le transfert vers WG terminé.

Je n’ai jamais observé le cas où le transfert vers WG ne se faisait pas et où Wswin32 resterait donc bloqué.

Mais il m’est arrivé (très rarement) d’autres cas de blocage de Wswin32, c’est pour cette raison que dans mon fonctionnement automatique il y a maintenant un .bat qui « tu les taches » (taskkill) en cas de blocage.
Voir explications détaillées ici :
http://michel.mo.pagesperso-orange.fr/m ... t_auto.htm

Depuis plusieurs années que ce système est en place la fiabilité de fonctionnement du PC, de Wswin32, donc des enregistrement et des transferts sur mon site est de 100%. (y compris pendant mes absences bien sûr).
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
vals
Participation 5
Participation 5
Messages : 810
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par vals » 12 oct. 2012, 19:23

Bonsoir à tous.
J'ai remarqué une chose c'est que depuis quelques mois quand on fait "Transférer les données maintenant" (la barre à coté de l'offset) dans l'onglet Wunderground avant ça durait une trentaine de secondes et maintenant il faut 10 minutes pour transférer les 24h.
Pourquoi, je ne sais pas ??
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

mm91
Participation 6
Participation 6
Messages : 2474
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: Wswin ne crée plus aucun fichier et ne s'arrête pas !!!

Message par mm91 » 12 oct. 2012, 20:15

vals a écrit :Bonsoir à tous.
J'ai remarqué une chose c'est que depuis quelques mois quand on fait "Transférer les données maintenant" (la barre à coté de l'offset) dans l'onglet Wunderground avant ça durait une trentaine de secondes et maintenant il faut 10 minutes pour transférer les 24h.
Pourquoi, je ne sais pas ??
Oui, tout à fait:
quand j'ai commencé à utiliser WG (février 2011) c'était beaucoup plus rapide (peut-être bien une trentaine de seconde ?)
Et brusquement, quelques temps après, c'est dvenu très long (environ 7 mn ici pour transférer les données des 24 dernières heures).
Je ne sais pas non plus ce qui s'est passé.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Répondre