retard de 1 jour sur mises à jour

Forum dédié aux différents bogues découverts ou aux éventuelles améliorations, peut être que Werner nous entendra !
Répondre
mm91
Participation 6
Participation 6
Messages : 2500
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

retard de 1 jour sur mises à jour

Message par mm91 » 18 juil. 2007, 07:26

Bonjour,

Je constate depuis quelques jours que tous les fichiers du type :

http://icare.cinq.free.fr/meteo/yesterday.gif
http://icare.cinq.free.fr/meteo/ddis_yesterday.gif
http://icare.cinq.free.fr/meteo/2007/20070716.gif
http://icare.cinq.free.fr/meteo/day1.gif

sont mis à jour avec un jour de retard.

Toutes les autres mises à jour journalières, par exemple
http://icare.cinq.free.fr/meteo/week.gif
http://icare.cinq.free.fr/meteo/2007/y2007st.gif

se font normalement au premier démarrage de Wswin32 après minuit et toutes les six heures (j’ai coché cette option).

Il semble que ce défaut se produit depuis que j’ai programmé le démarrage de Wswin32 pour que le premier enregistrement ait lieu à 6h pile du matin : conflit entre premier démarrage et « toutes les 6 heures » ?

Je vais faire des essais, mais cela est un peu long (un seul test possible par jour).
Avez-vous des pistes d’investigation ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
chriss
Participation 5
Participation 5
Messages : 948
Enregistré le : 31 mai 2007, 16:30
Localisation : Plévenon (22)
Contact :

Message par chriss » 18 juil. 2007, 08:55

En cochant "mise a jour au démarrage" dans "internet"==>"réglages"==>onglet "généralités" ça fera la mise a jour au démarrage du programme et toute les 6h ensuite.

mm91
Participation 6
Participation 6
Messages : 2500
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Message par mm91 » 18 juil. 2007, 09:15

chriss a écrit :En cochant "mise a jour au démarrage" dans "internet"==>"réglages"==>onglet "généralités" ça fera la mise a jour au démarrage du programme et toute les 6h ensuite.
oui, peut-être, mais je ne veux pas faire une mise à jour à chaque démarrage du programme.
Cela fonctionnait bien jusqu'à maintenant, et je voudrais surtout comprendre ce qui a pu changer le fonctionnement.
Si je coche cette option (qui n'a jamais été cochée) je ne saurais jamais ce qui s'est passé.
Dans les prochains jour je vais faire l'essai de changer l'heure programmée de démarrage de Wswin32.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Avatar du membre
chriss
Participation 5
Participation 5
Messages : 948
Enregistré le : 31 mai 2007, 16:30
Localisation : Plévenon (22)
Contact :

Message par chriss » 18 juil. 2007, 23:41

Je pense que le fait de demander a wswin de commencer l'enregistrement à 6h doit empecher que cette mise a jour se fasse a 6h..
Peut-être qu'en mettant quelque minute offsets ca fonctionnerais, j'en suis meme certains.
Au dessus de la case où vous avez coché 6h (pour le pas de mise a jour) se trouve la case des minutes offsets, il suffit de rentrer 1 ou 2 min, je pense que ca devrais suffir, et ainsi wswin aura d'abord le temps de lire le fichier d'heavy weather et de convertir et ensuite il va pouvoir faire les mise a jour avec les nouvelles données apportés.

Avatar du membre
vals
Participation 5
Participation 5
Messages : 814
Enregistré le : 13 déc. 2006, 20:27
Localisation : 69320 Feyzin
Contact :

Message par vals » 19 juil. 2007, 20:05

Bonsoir.
Pour ma part je suis à un pas de mesure toutes les 5 minutes et mise à jour toutes les 3 heures.
Sans temps d'offset les mises à jour se font à par exemple à 15h05, 18h05 et non à 15:00 ou 18:00 heures.
Cordialement.
Image
Davis VantagePro2 + Wswin32 V2.96.10 + GraphWeather + ftp-uploader. Webcam.

Avatar du membre
chriss
Participation 5
Participation 5
Messages : 948
Enregistré le : 31 mai 2007, 16:30
Localisation : Plévenon (22)
Contact :

Message par chriss » 19 juil. 2007, 20:26

Mais ici le problème est que la mise à jour se fait à 6h précise mais que l'enregistrement des données aussi.. Il y a donc un conflit et seul l'enregistrement des données se fait.. La mise a jour des fichier se fera donc 6h plus tard, c'est-à-dire à 12h.. Par contre en mettant une a deux minute offset alors wswin enregitrera les données a 6h ensuite a 6h02 il fera les mise a jour...

jackT
Participation 4
Participation 4
Messages : 635
Enregistré le : 29 mars 2007, 11:24
Localisation : Sciez (74)
Contact :

Re: retard de 1 jour sur mises à jour

Message par jackT » 29 juil. 2007, 18:44

Bonjour Michel,

L'heure et la date de ton PC et celle de ta ws2300 sont-t'ils les mêmes?

mm91
Participation 6
Participation 6
Messages : 2500
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: retard de 1 jour sur mises à jour

Message par mm91 » 06 août 2007, 13:36

jackT a écrit :Bonjour Michel,

L'heure et la date de ton PC et celle de ta ws2300 sont-t'ils les mêmes?
Oui, toujours,
à moins de une minute près: c'est ce que j'obtiens entre l'heure station radiopilotée et le temps Internet synchronisé automatiquement une fois par jour (je n'ai jamais compris pourquoi une telle différence ?).

Ce problème ne s'est plus reproduit.
Il était du à une programation différente et provisoire de mes tâches planifiées.
Certainement une histoire d'offset comme vous me l'avez suggéré.

Je n'ai pas approfondi la question puisque le pb ne se pose pas avec la planification habituelle des tâches.
Voir éventuellement:
"2/Enregistrer et transférer automatiquement sur site perso, même en cas d’absence"
ici:
http://perso.orange.fr/michel.mo/meteo/ ... atique.htm

merci à tous.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Répondre