%ws_summertimestart%

Forum destiné aux problèmes de Tags, recherche d’une fonction, d’un calcul, Tag qui parait ne pas fonctionner, du Tag et rien que du Tag !
Répondre
doubleau
Participation 2
Participation 2
Messages : 139
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

%ws_summertimestart%

Message par doubleau » 12 févr. 2014, 10:54

Ce tag indiquant la date et l'heure du passage à l'heure d'été retourne parfois un horaire avec les secondes : 02:00:00 30 03 2014. Sans que je modifie quoi que ce soit, il retourne d'autres fois le même horaire, mais sans les secondes.
Je ne pense pas que l'indication des secondes soit nécessaire. Que faut-il régler pour avoir un affichage de l'horaire sans les secondes ?
Même phénomène avec %ws_summertimeend%
Avez-vous également ce problème ?

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_summertimestart%

Message par mm91 » 12 févr. 2014, 17:28

J'utilise aussi ces deux tags dans ma page custom;
voir paragraphe "Soleil / Changements d'heure" dans cette page: http://icare.cinq.free.fr/meteo/courrent.html

mais les heures y sont toujours indiquées sans les secondes.
(comme sur ta page: http://www.meteo-mussidan.fr/aff_moncustom.php actuellement)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

doubleau
Participation 2
Participation 2
Messages : 139
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

Re: %ws_summertimestart%

Message par doubleau » 12 févr. 2014, 23:21

Merci pour ta réponse.
Le problème est que les secondes ne sont pas toujours indiquées, mais parfois elles le sont !
C'est bien cela que je cherche à comprendre : pourquoi les secondes s'affichent-elles parfois ?

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_summertimestart%

Message par mm91 » 13 févr. 2014, 08:53

J'ai cherché et j'ai fait pas mal d'essais:

si je mets:

%ws_userdate=DD-MM-YYYY%

avant le calcul, j'obtiens l'heure avec les secondes, comme ça:

02:00:00 30/03/2014

si j'enlève:

%ws_userdate=DD-MM-YYYY%

j'ai toujours l'heure avec les secondes !

si je mets:

%ws_userdate=%

avant le calcul, je n'ai plus les secondes, comme ça:

02:00 30/03/2014


Conclusion:

mets:

%ws_userdate=%

avant ton calcul.




Pour mémoire, extrait de "ws_variables_en _français.txt": (*)

%ws_userdate=YYYY-MM-DD%
Change le format de la date (il suffit de placer les lettres dans l'ordre dans lequel on veut que la date soit affiché.

%ws_userdate=%
Permet de revenir au format de la date définit dans windows.




(*)
disponible ici: http://www.plevenon-meteo.info/ws_variables_fr.html
(attention cette traduction n'est pas récente, sur le site de Werner il y a des versions en anglais plus récentes)
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

doubleau
Participation 2
Participation 2
Messages : 139
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

Re: %ws_summertimestart%

Message par doubleau » 13 févr. 2014, 10:23

Merci beaucoup pour ton travail de recherche et d'explication.

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_summertimestart%

Message par mm91 » 13 févr. 2014, 10:45

doubleau a écrit :Merci beaucoup pour ton travail de recherche et d'explication.
Oui, mais maintenant tu es "obligé" de faire l'essai indiqué et de nous donner le résultat ! :lol:


PS:
vérifie bien, après avoir fait la modification indiquée, que les autres dates / heures de ta page ne sont pas modifiées d'une façon non souhaitée.
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

doubleau
Participation 2
Participation 2
Messages : 139
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

Re: %ws_summertimestart%

Message par doubleau » 14 févr. 2014, 16:51

Jusqu'à présent, les horaires s'affichent sans les secondes et il n'y a pas eu d'incidence sur les autres dates de la page.
Tout est bien !

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_summertimestart%

Message par mm91 » 14 févr. 2014, 20:06

doubleau a écrit :Jusqu'à présent, les horaires s'affichent sans les secondes et il n'y a pas eu d'incidence sur les autres dates de la page.
Tout est bien !
donc tu as utilisé le tag:

%ws_userdate=%

c'est bien ça ?
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

doubleau
Participation 2
Participation 2
Messages : 139
Enregistré le : 12 févr. 2010, 18:41
Localisation : Mussidan (Dordogne)
Contact :

Re: %ws_summertimestart%

Message par doubleau » 14 févr. 2014, 23:34

Oui, exactement, comme tu me l'avais conseillé.
Merci

mm91
Participation 6
Participation 6
Messages : 2494
Enregistré le : 31 mars 2007, 07:46
Localisation : 25 Km au sud-ouest de Paris FRANCE
Contact :

Re: %ws_summertimestart%

Message par mm91 » 15 févr. 2014, 08:01

OK, merci
Michel
La Crosse WS2300 modifiée (pluvio, abri ventilé, mesure d'ensoleillement), Wswin32, ftp-uploader.
mon site météo

Répondre